Tutorial stuck and I can't finish it

So, when I signed on the other day, I did the basic new user tutorial. I got to the @ mention step, did a mention of discobot and nothing new happened. I waited, and eventually it said “I haven’t heard from you in awhile” but I was not able to finish the tutorial. I tried it again and got stuck at the same step:

So, just for fun, I started the advanced tutorial (trying to acquire badges…) and then got to the edit a post to hide spoilers - I didn’t edit the “text in quotes”, but did create the hidden stuff - and it got stuck. No reply from discobot.


I don’t want to start over yet again…but I’d like to be able to finish. Is there a command to pick up where you left off? Or did restarting just bug it out?

1 Like

Hmmm. Based on my limited understanding, this can sometimes happen if you haven’t advanced to TL1, but you are. @CinnamonFridge do you have any ideas? Meta is less than helpful on this, since such topics tend to be closed if they can’t reproduce them.

I know you can start the tutorial with

@discobot start advanced tutorial 
3 Likes

I’ve never seen the tutorial get stuck for someone who is already TL1. I know when it gets stuck for TL0 users that deleting all the messages from @discobot and then starting a new PM with @discobot start new user will usually work to restart it and have it proceed correctly.

@Kyrthanna_Elvendahl If you send these commands to discobot in a PM does it respond? @discobot quote and @discobot fortune

2 Likes

Yes, those work fine. And I can restart it fine (because I restarted the first one and got stuck again), but it gets to a certain point and doesn’t reply again, other than to wait, and eventually tell me it hasn’t heard from me in a while.

Do you think deleting the messages and starting over will fix it? Or is that not an option because I’m already at the first trust level?

1 Like

It has nothing to do with trust level. You could be trust 4 and complete the tutorial.

Have you tried mentioning @discobot without any text? That’s what I did (not that it should matter)

2 Likes

Hi! To find out what I can do, say @discobot display help.

1 Like

Is the tutorial started by following the instructions in the opening discobot message? This one?

If so, I like the playfulness of the message. It is a really fun idea. However, I missed it and worry that a lot of new users are going to miss it and not even realize there is a tutorial. Others might choose not to bookmark a bot conversation, not realizing its value.

Would there be a way to perhaps put the instructions to start the tutorial in the basic tutorial badge description? I found the badge but had to find this thread to find the atdiscobot command.

Unless you manage to hit a very specific bug that is almost impossible to duplicate where the tutorial gets stuck at the step where you have to mention discobot in a message to continue. I’ve personally seen the bug several times and until now I’ve only ever seen it affect TL0 users.

Sorry I missed this. Yeah, that should work. Like I said, I’ve not seen it get stuck like that for someone who is TL1, but in theory it should fix it if the cause is the same.

1 Like

Thanks for the suggestion. Sorry, life pulled me away and I’m just now seeing this. I tried that just now (without deleting the message thread) and got this reply: Hi! To find out what I can do, say @discobot display help .

I typed that and just got the regular help commands. Guess I’ll have to try just deleting and starting the tutorial over. I’ll update the thread once I’ve been able to do that. Thanks again!

Thanks! I just tried Xander’s suggestion and posted what happened. I will try deleting the thread and starting over and let you know if I still end up being stuck or if it lets me finish the tutorial. :slight_smile:

Not sure about this. If I’m in the main message area, it only lets me “archive” the thread. And it won’t let me start a new message to Discobot - it gives an error saying that’s not a valid user to send a message to. Clicking on individual posts, it only lets me delete MINE, not Discobot’s - I’m only allowed to flag or bookmark Discobot’s. Is there somewhere I’m not seeing that will allow me to delete these and restart? Or @CinnamonFridge did you mean for me to just delete MY replies, not the entire thread?
Thanks for trying to help with this…

hi! just popping in to say that i had this exact problem the first time i attempted the tutorial and what worked for me was archiving the entire thread and messaging discobot to start over. after, i was able to complete the full tutorial. not sure why it won’t let you send a new message though - maybe you can only have one thread per user?

1 Like

Hi,

I’ve gotten stuck too, at the bit where you post an image. I told the bot I couldn’t find one because I’m blind, so it sent me a link to post, but posting that didn’t get a reply, and I couldn’t find how to delete the thread…

Edit: Archived and also can’t message discobot. :frowning: Now I don’t know what else to do…

Try typing the command to restart the tutorial in this thread. It should still cause discobot to restart the tutorial for you.

@discobot start tutorial

It worked and I finished it! :slight_smile: Thanks, @CinnamonFridge!

1 Like

I agree with this. I had seen that there was an advanced tutorial badge a few days ago (didn’t learn about the discobot functions until today), but I was confused about how to start it until I saw this thread. Perhaps there should be an automatic message when someone first gets on the site that explains what the discobot is and some of the essential functions it can do, such as starting the new user/advanced tutorials.

1 Like

https://forums.nanowrimo.org/t/welcome-to-the-new-test-board-now-what/331/18

Discobot messages you automatically at some point shortly after you join and prompts you to start the tutorial. At the end of the tutorial it hints there’s more it can teach you. You to start begging it, it will eventually suggest you ask for ‘help’ (ie it won’t know what to do to it suggests you look up the command list) which will explain how to start the advanced tutorial.

Hi! To find out what I can do, say @discobot display help.